*2010-03-18 (hazen) *

Added HowtoProgramDTCFirmware link to main page with detailed flash programming instructions.

2010-03-16 (Mike)

I was able to get a simple OpenIPMI program to interface with the board. The program is a trivially (for now) modified version of

  ~msdim/ipmi/OpenIPMI-2.0.14/sample/ipmisample.c
and is run:
   $ ./ipmisample lan 192.168.1.10
The program is very basic--it just loops through the sensors and outputs their readings (temperature, voltage, etc) and waits for any changes.

As for getting/setting registry values, there seems to be some relevant functions in the "ipmi_fru.h" file, namely:

  int ipmi_fru_node_get_field(...)
  int ipmi_fru_node_set_field(...)
The ipmi header files are well commented, so trying to implement the above functions could be a good next step.

2010-03-12 (hazen)

Updated CPLD firmware, hardware mods. Now, temperature is 25C as expected. Will try to program FPGA flash. Need a binary file... assuming this would be a raw binary image of the MCS hex file. Install the "srecord" Debian package on cms1, convert as follows:

  $ srec_cat DTC_test.mcs  -Guess -Output DTC_test.bin -Binary

This produces a binary file which by inspection (od -Ax -v -t x1 file.bin) is identical to the hex file. Let's give it a try!

Doesn't work. Use "diag" menu on MCH, option 9 (CLK board), option 2 (FPGA), get this error:

  ERR unsupported PCB V0.0 or MC version V1.0 

2010-03-11 (hazen)

Can access with ipmitool as follows:

[cms1] ~/NatView/ipmitool-1.8.11/src > ./ipmitool -H 192.168.1.10 -A NONE sdr list all
NAT-MCH-MCMC     | Log FRU @03h c2.61 | ok
Temp CPU         | 28 degrees C      | ok
Temp I/O         | 26 degrees C      | ok
HotSwap          | Not Readable      | ns
Version Change   | Not Readable      | ns
Volt 1.2V        | 1.20 Volts        | ok
Volt 1.5V        | 1.50 Volts        | ok
Volt 1.8V        | 1.80 Volts        | ok
Volt 2.5V        | 2.51 Volts        | ok
Volt 3.3V        | 2.66 Volts        | ok
Volt 12V         | 7.80 Volts        | ok
Base Current     | disabled          | ns
BP-FRU-253       | Phy FRU @A4h d0.61 | ok
BP-FRU-254       | Phy FRU @A4h f2.61 | ok
MCH-DTC          | Log FRU @3Ch c2.63 | ok
Temp Clock       | -1 degrees C      | nc
NMCH-CM          | Log FRU @00h c2.61 | ok
CEN Power Modul  | Log FRU @32h 0a.61 | ok
Hot Swap         | disabled          | ns
Temp Sensor 1    | 206 degrees C     | ok
Temp Sensor 2    | 255 degrees C     | ok
NMCH-ShM         | Dynamic MC @ 20h  | ok
[cms1] ~/NatView/ipmitool-1.8.11/src > 

Now trying to figure out to R/W arbitrary registers. Reading paper from openipmi web page.

2010-03-10 - Spring break, no notes from Mike, on my own frown

Connect micro-USB cable to eeePC laptop. Install minicom. Run "sudo minicom -s" and set serial port to /dev/ttyACM0 as gleaned from dmesg output. Works fine, can talk to console.

Instructions to program clock module firmware:

  Unzip the file (clkmod.zip) and store it to a tftp-server. Use the diag menu of the MCH firmware:
  diag -> 10 ->2 ->2 -> IP:/folder/clkmod.hex 

Instructions to program FPGA flash via SPI:

  diag-> 9 (CLOCK PCB menu) -> 1 (FPGA update) -> 7 (program file to FLASH) -> enter Loops: 1 -> IP:/folder/file
  Only binary formats are supported (e.g. for Altera *.rpd files or *.bin files for Lattice). 

Try to program AVR. Doesn't work:

DIAG (RET=0/0x0): 10
  [ 0] : no action (unsupported)
  [ 1] : (submenu) AVR PROG menu 
  [ 2] : program firmware to AVR flash 
  [ 3] : verify firmware in AVR flash 
  [ 4] : show board information 
  [ 5] : set board information 
  [ 6] : reset AVR device 
  [ ?] : ?: help 
  [ h] : h: help 
  [ q] : q: quit submenu 
AVR (RET=0/0x0): 2
Choose AVR device:
   LED module AVR      : 0
   HS AVR              : 1
   CLOCK PCB AVR       : 2
   HUB PCB AVR         : 3
AVR device (RET=2/0x2): 2
Enter host and file name of AVR firmware hex-image
[IP:FILENAME]:>192.168.1.1:clkmod.hex
TFTP: getting BIN file:
  192.168.1.1:clkmod.hex
.....
TFTP: getting file done (28916 bytes)
avr_prog_enable: ERR retry timeout
AvrProg_Init(2): ERR avr_prog_enable failed
avr_prog_init(2): ERR AvrProg_Init failure -6
Nmch_AvrProgBuf(2): ERR avr_prog_init failure -3
Nmch_AvrProgFile(2): ERR Nmch_AvrProgBuf failure -3

Update MCH firmware to latest using update_firmware with nmch_mch.bin file just received. Power-cycle after. MCH comes up ok, but still can't program AVR.

OK, found the problem. The nRESET pin on the AVR is connected to the wrong pin (HUB card reset instead of CLK card reset) on the 28-pin mezzanine connector. If we select '3' (HUB card) then we can program the AVR.

2010-01-25 - Working with Mike. Tried to connect to NAT-MCH using USB console. Worked once on Mike's vista laptop, then not again.

Try again on L3 XP machine. First time USB device is unrecognized, but observe that Mike has downloaded the nat-mch.inf file. Use the device manager to load this driver file, then it works using teraterm. Only problem seen is that one must exit teraterm before power cycling the uTCA crate, otherwise it won't connect.

The recover procedure which seems to always work is to exit Teraterm, then (with uTCA power on) unplug the USB cable, count to 5, then replug and count to 5. Then start Teraterm and select 'com4'. This has now worked many times.

2010-01-26 - Still can't connect via ethernet. Using eth1 with x-over cable on cms1. Capture packets with nmap... see arp request with no replay. Manually add to arp tables with:

sudo /sbin/arp -s 192.168.1.41 00:e0:81:32:12:b3

Still fails. Try cabling to regular switch on 43 subnet, assign unused I/P address 'cms3.bu.edu'. Same problem. Have to take a break for now.

10am - still no luck. Tried tracking with wireshark... see a 'Ping' sent to port 623, reply is 'destination unreachable' Try C client/server pair on port 623 and it works but requires sudo. Try running natview with sudo... no luck. Also try ipmitool (normal and sudo) with same results.

Back to private network. Set I/P = 192.168.1.10. Change cables. Switch from long "Cat 5" (cross-over?) cable to 15' "Cat 6" new yellow cable. Ping works, so no need for crossover. Same problem.

-- EricHazen - 26 Jan 2010

Edit | Attach | Watch | Print version | History: r27 | r12 < r11 < r10 < r9 | Backlinks | Raw View | Raw edit | More topic actions...
Topic revision: r10 - 18 Mar 2010 - EricHazen
 
  • Edit
  • Attach
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2020 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback